zjfc1076 online judge 对多行字符串输入做处理
摘要:str[0]=“\0”;“\n”);int len=strlen(s);tmp[j++]=s[i];}tmp[j]=“\0”;b) ==0)printf(“已接受\n”);
题目描述
Ignatius is building an Online Judge, now he has worked out all the problems except the Judge System. The system has to read data from correct output file and user's result file, then the system compare the two files. If the two files are absolutly same, then the Judge System return "Accepted", else if the only differences between the two files are spaces(' '), tabs('\t'), or enters('\n'), the Judge System should return "Presentation Error", else the system will return "Wrong Answer".
Given the data of correct output file and the data of user's result file, your task is to determine which result the Judge System will return.
输入描述
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case has two parts, the data of correct output file and the data of the user's result file. Both of them are starts with a single line contains a string "START" and end with a single line contains a string "END", these two strings are not the data. In other words, the data is between the two strings. The data will at most 5000 characters.
输出描述
For each test cases, you should output the the result Judge System should return.
样例输入
4
START
1 + 2 = 3
END
START
1+2=3
END
START
1 + 2 = 3
END
START
1 + 2 = 3
END
START
1 + 2 = 3
END
START
1 + 2 = 4
END
START
1 + 2 = 3
END
START
1 + 2 = 3
END
样例输出
Presentation Error
Presentation Error
Wrong Answer
Presentation Error
Code
#include<stdio.h>
#include<string.h>
char a[5005],b[5005],tmp[5005];
int t;
void input(char *str)
{
getchar();
gets(tmp);
str[0]='\0';
while(gets(tmp)&&strcmp(tmp,"END")){
if(strlen(tmp)==0)
strcat(str,"\n");
else
strcat(str,tmp);
}
}
void mdo(char *s)
{
int i,j;
int len=strlen(s);
for(i=0,j=0;i<len;i++){
if(s[i]==' '||s[i]=='\t'||s[i]=='\n')
continue;
tmp[j++]=s[i];
}
tmp[j]='\0';
strcpy(s,tmp);
}
int process()
{
mdo(a);mdo(b);
if(strcmp(a,b)==0)
return 1;
return 0;
}
int main()
{
scanf("%d",&t);
while(t--){
input(a);
input(b);
if(strcmp(a,b)==0)
printf("Accepted\n");
else if(process())
printf("Presentation Error\n");
else
printf("Wrong Answer\n");
}
}
免责声明:文章转载自《zjfc1076 online judge 对多行字符串输入做处理》仅用于学习参考。如对内容有疑问,请及时联系本站处理。
上篇Asp.Net 之 基本控件FileUpload上传控件Ubuntu使用笔记下篇
宿迁高防,2C2G15M,22元/月;香港BGP,2C5G5M,25元/月 雨云优惠码:MjYwNzM=
前后台没有分开,为了区分前后台用户,所以分表,但是ID不能重复,因为关联了权限表. 这里实现后台用户表使用奇数ID 前台用户表使用偶数ID MYSQL 没有sequence SET @@auto_increment_offsetSET @@auto_increment_increment 也只能在当前查询有效.所以这也是权宜之计 SET FOREIGN...